Is my smartphone compatible?

Apple: iOS 8 or higher:

  • iPhone 4s, iPhone 5, iPhone 5s, iPhone 5c, iPhone 6 or higher.
  • iPod touch ( 5th generation ) or higher.

Android: The GYMWATCH sensor supports most new Android smartphones:

  • Version 4.1 Jelly Bean - API level 18 - or higher is required

 

Have more questions? Submit a request

Comments

Powered by Zendesk